Delays in Job Processing

Incident Report for Semaphore CI

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 19:24 UTC

Monitoring

We’re seeing considerable improvement in internal performance metrics, and we will continue monitoring until conditions fully stabilize.
Posted Feb 03, 2026 - 18:52 UTC

Investigating

Webhook delivery delays from GitHub led to a backlog of workflows being triggered all at once as delivery resumes. This caused a temporary spike in demand for some Semaphore machines.

We are actively working to reduce the impact and restore normal capacity. We continue monitoring both GitHub’s incident and Semaphore infrastructure closely, and we will provide further updates as conditions stabilize.
Posted Feb 03, 2026 - 18:06 UTC
This incident affected: Semaphore.