Delays when checking out GitHub repos via SSH

Incident Report for Semaphore CI

Resolved

This incident has been resolved.
Posted May 19, 2026 - 15:42 UTC

Monitoring

We are not currently seeing timeouts related to slow connections. Our team is continuing to monitor the situation to confirm that service has fully returned to normal.
Posted May 19, 2026 - 15:10 UTC

Identified

We identified that the issue is slow communication between our jobs and GitHub. We are currently working with our upstream provider to to resolve this. For impacted jobs, please replace the normal checkout command with the following:

retry --times 5 "timeout 40 bash -lc 'source ~/.toolbox/toolbox; checkout'"

And afterwards, use cd to change the directory to the cloned repository (replace with your project).
Posted May 19, 2026 - 11:18 UTC

Update

We are continuing to investigate this issue.
Posted May 19, 2026 - 10:38 UTC

Investigating

We are currently investigating this issue.
Posted May 19, 2026 - 10:00 UTC
This incident affected: Semaphore.