Network connectivity issues towards us-east

Incident Report for Semaphore CI

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 18:10 UTC

Monitoring

The connection seems stable and we keep monitoring it.
Posted Nov 12, 2025 - 17:34 UTC

Identified

We’ve identified that these issues are being caused by inconsistent network routing between Europe and the United States on upstream providers.
Semaphore’s systems remain healthy, but affected routes can cause slower file transfer and occasional connection timeouts.
Posted Nov 12, 2025 - 16:24 UTC

Update

We are continuing to investigate this issue.
Posted Nov 12, 2025 - 15:28 UTC

Investigating

We are currently investigating the issue.

Implementing the retry command should help mitigate the issue: https://docs.semaphore.io/reference/toolbox#retry
Posted Nov 12, 2025 - 14:55 UTC
This incident affected: Semaphore.