The issue has since appeared to subside, but we're continuing to monitor the situation on our end.
Posted Sep 02, 2026 - 14:19 UTC
Update
We have found that this is currently a wider situation impacting HTTPS operations, which is also affecting Semaphore and our users. You can read more about this in this thread: https://github.com/orgs/community/discussions/206581
As a workaround, you can configure git to use only HTTP/1.1, using the following command: git config --global http.version HTTP/1.1
We are continuing to monitor and investigate this situation on our end.
Posted Sep 02, 2026 - 13:56 UTC
Update
We have found that this is currently a wider situation impacting HTTPS operations, which is also affecting Semaphore and our users. You can read more about this in this thread: https://github.com/orgs/community/discussions/206581
As a workaround, you can configure git to use only HTTP/1.1, using the following command: git config --global http.version HTTP/1.1
We are continuing to monitor and investigate this situation on our end.
Posted Sep 02, 2026 - 13:29 UTC
Identified
We have found that this is currently a wider situation impacting HTTPS operations, which is also affecting Semaphore and our users. You can read more about this in this thread: https://github.com/orgs/community/discussions/206581
As a workaround, you can configure git to use only HTTP/1.1, using the following command: git config --global http.version HTTP/1.1
Please also note that we are continuing to monitor and investigate this situation on our end.
Posted Sep 02, 2026 - 12:53 UTC
Update
We are continuing to investigate this issue.
Posted Sep 02, 2026 - 12:18 UTC
Update
We are still looking into the cause of this issue, but as a temporary workaround, you can add the following environment variable to your jobs, which will cause them to immediately fail and not hang:
GIT_TERMINAL_PROMPT=0
After they fail, you can rerun the pipeline, and only the failed jobs should rerun, allowing you to work through this issue until we have more information to share.