Delivering webhooks delays between Github and Semaphore

Incident Report for Semaphore CI

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 19:50 UTC

Monitoring

GitHub has posted an update indicating recovery of the aforementioned issue. We continue monitoring Semaphore closely as things stabilize.

(GitHub Status: https://www.githubstatus.com/incidents/f314nlctbfs5)
Posted Feb 03, 2026 - 19:11 UTC

Identified

Webhook delivery delays between GitHub and Semaphore appear to be caused by degraded performance on GitHub’s side. GitHub is currently reporting an active incident that appears related. We are monitoring the situation closely and will provide updates as GitHub resolves the issue.
Posted Feb 03, 2026 - 17:34 UTC

Investigating

We are currently investigating this issue.
Posted Feb 03, 2026 - 15:46 UTC
This incident affected: Semaphore.